Portal service disruption

Incident Report for Filemark

Resolved

This issue has been resolved. Portal has returned to normal operation.
Posted Jul 23, 2026 - 13:56 EDT

Investigating

We are investigating a service disruption affecting the portal. This issue will auto-resolve when service is restored.
Posted Jul 23, 2026 - 13:55 EDT
This incident affected: Client Portal.